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Introduction

Welcome!

Welcome to PlanMaker, the powerful and easy-to-use spreadsheet application
for Windows, Linux, Pocket PCs, and Handheld PCs.

Functional Overview

We have made every effort in the development of PlanMaker to integrate its
functions to provide the maximum benefit while minimizing user time and
effort.

Some of PlanMaker's Features:

 Available for PCs (Windows and Linux), Pocket PCs, and Handheld PCs

 PlanMaker has more than 320 built-in mathematical functions.

 The integrated charting module allows you to present numbers vividly in
charts.

 Creating attractive worksheets is made easy through numerous formatting
options. Long, boring columns of numbers can be turned into attractive
worksheets with the AutoFormat command. With cell stylesheets and
character stylesheets, you apply frequently needed formatting through a
simple key press.

 The full range of PlanMaker functions is available through a well-
designed, ergonomic user interface that includes user-configurable tool-
bars and keyboard mappings, as well as context menus (accessible with
the right mouse button).

 ...and much more!
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PlanMaker is in continuing development and we welcome comments and
suggestions from our users.

Technical Support

If you want to contact us for technical support, you have the following op-
tions:

World Wide Web: www.softmaker.com

Our web site is kept current with answers to frequently asked questions, the
latest program updates, and much more. Visit us at: www.softmaker.com

Support Forums at www.softmaker.com/forum

The easiest way to communicate with our technical support team as well as
other users is to visit our support forums at: www.softmaker.com/forum

E-mail

You can send support-related e-mail to: support@softmaker.com

Fax or Snail Mail

You can mail or fax questions to us at:

SoftMaker Software GmbH
Kronacher Str. 7
D-90427 Nuremberg
Germany

Fax: +49-911-303796
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Phone

You can also phone us. Before calling, please have your customer number
ready. The number of our technical support department is:

Phone: +49-911-936 386 50

About this Manual

PlanMaker has been developed with an understanding that there is a broad
range of user experience. While it has many functions and customization
options for the advanced user, it is designed to be an extremely useful tool for
the novice as well.

The chapters of this manual are organized as follows:

 Chapter "Installing and Starting PlanMaker" (page 11): Describes how to
install PlanMaker

 Chapter "Screen Elements" (page 17): Describes the individual compo-
nents of PlanMaker's application window.

 Chapter "PlanMaker Basics" (page 25): Describes the basic functions of
PlanMaker and explains basic spreadsheet terminology.

 Chapter "The PlanMaker Tour" (page 33): Provides an introduction into the
practical use of spreadsheets

Typographical Conventions

In this manual, menu commands and dialog box components are in boldface
type. File > New, for example, describes the command New in the File menu.

File names are represented as follows: c:\images\beach.bmp

The Enter key is represented by (¢), the arrow keys by (æ), (Æ) etc. To enter
a key combination such as (Alt)(F), press the (F) key while at the same time
holding down the (Alt) key.
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Note: A text section highlighted like this contains important information or
useful hints.

System Requirements

To use this software, you need the following hardware and software:

Windows Version

 Windows 95 or higher
 CD or DVD drive
 RAM requirements:

Windows 95: 8 MB
Windows 98 and NT: 16 MB
Windows ME: 32 MB
Windows 2000 and XP: 64 MB

Pocket PC Version

 Pocket PC 2000/2002/2003, Windows Mobile 2003/2003 SE, or Pocket PC
Phone Edition

 Required memory:
6 MB storage memory (can be installed on a memory card)
3 MB program memory (while PlanMaker is running)

Handheld PC Version

 Handheld PC with a screen resolution of at least 640 x 240
 Windows CE 2.11, or higher, or Windows CE.NET
 Required memory:

6 MB storage memory (can be installed on a memory card)
3 MB program memory (while PlanMaker is running)
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Linux Version

 CD or DVD drive
 Any glibc-based x86-Linux with kernel 2.0 or higher
 X Window system with any window manager





Quick Start PlanMaker 2004 Installing and Starting PlanMaker  •  11

Installing and Starting PlanMaker

Overview: Installing and Starting PlanMaker

In this chapter you will find out how to install and start PlanMaker.

The chapter is divided into the following sections:

 Installing PlanMaker for Windows (page 11)

 Installing PlanMaker for Pocket PCs (page 14)

 Installing PlanMaker for Handheld PCs (page 15)

 Installing PlanMaker for Linux (page 15)

Please go directly to the section that is suitable for your operating system.

Installing PlanMaker for Windows

Note: If you are using Windows NT/2000/XP, Administrator login is re-
quired for installation.

Note: If your computer is attached to a local area network (LAN), in addition
to the following information, please read section "Using PlanMaker on Local
Area Networks (Windows-only)" below (page 12).

Download

If you purchased PlanMaker as a download from our web site, you will find
installation instructions included in the e-mail that you received after pur-
chasing the software.



12  •  Installing and Starting PlanMaker Quick Start PlanMaker 2004

CD-ROM

If you have received PlanMaker on CD-ROM, please insert the installation CD
into your CD-ROM drive and follow the installation instructions displayed.

If the installation program is not started automatically on your computer, you can start it manu-
ally by double-clicking the program file Setup on the installation CD.

For a first-time install you will need to enter your serial number (found on the
CD wrapper).

For an upgrade install you will first need to enter the serial number from your
previous version of PlanMaker (printed on the original CD wrapper) followed
by the upgrade product code (printed on the new CD wrapper).

Starting PlanMaker for Windows

Note: If your computer is attached to a local area network (LAN), in addition
to the following information, please read section "Using PlanMaker on Local
Area Networks (Windows-only)" below (page 12).

Use the Start menu to start the installed programs. Click e.g. Start > Programs
> SoftMaker Office > PlanMaker to open PlanMaker.

Note: When opening PlanMaker for the first time, you will be asked to enter your name and
contact info. This is not for registration purposes. It will allow you to insert your name, mailing
address, etc. in documents through the USERFIELD function. You can change this information at
any time.

Using PlanMaker on Local Area Networks (Windows-only)

Note: This section is relevant for Windows users only.

If you plan to use PlanMaker for Windows on a computer that is connected to
a local area network (LAN), please read the following information carefully.



Quick Start PlanMaker 2004 Installing and Starting PlanMaker  •  13

Installing PlanMaker for Windows on a Local Area Network

To install PlanMaker on a local area network (LAN), you should first perform
a normal installation of PlanMaker (as described above in section "Installing
PlanMaker for Windows").

Tip: To simplify the installation on additional computers and administration
of the user files, it is advisable to install PlanMaker to a shared file folder
(e.g., on a file server) that is accessible to all PlanMaker users.

Setting Up Additional Workstations on the Same Network

Note: Skip this section if you plan to use PlanMaker on a single workstation
only.

Follow this procedure if PlanMaker is to be used on multiple computers
connected to the same local network:

Basic Installation

First perform a normal installation of PlanMaker on one of the network
computers, then, in order to give other network computers access to Plan-
Maker, share the folder where PlanMaker is installed.

Preparing Additional Workstations

After the regular install on one computer, PlanMaker can easily be set up on
additional workstations.

To facilitate installation, PlanMaker has an automatic installation routine. All
you have to do is to manually start PlanMaker on the workstation:

1. Open the Windows Explorer.

2. Navigate to the shared folder on the file server where PlanMaker is in-
stalled.

3. Navigate to the Program Files folder within the shared folder.

4. Double-click the program file pmw32 to open the PlanMaker application.
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5. Follow the Set-up Wizard prompts to configure PlanMaker automatically.

Initial Set-up of PlanMaker for Windows on a Workstation

If your computer is attached to a local area network (LAN), you will be asked
to create a new user profile the first time you start PlanMaker. PlanMaker
stores all your personal program settings in this user profile:

 User preferences (including keyboard layout and toolbars)
 User dictionaries (used by the spell-checker)
 Personalized SmartText glossary entries

To create a new user profile, simply enter the name under which you want to
store the profile. PlanMaker automatically suggests your Windows login
name, which you can accept or change.

PlanMaker now creates a user profile and stores all future settings changes
you make to this profile.

Please Pay Attention to your License Agreement!

Note: The Software License Agreement allows you to install PlanMaker on
multiple computers – however, only one copy of the program may run at
any point. If several users will be running PlanMaker simultaneously, you
have to purchase a corresponding number of PlanMaker licenses.

Installing PlanMaker for Pocket PCs

Information on installing PlanMaker can be found in the confirmation e-mail
that you received after purchasing the software.

Note: If you are using Windows NT/2000/XP, Administrator login is re-
quired for installation.



Quick Start PlanMaker 2004 Installing and Starting PlanMaker  •  15

Starting PlanMaker for Pocket PCs

Use the Start menu of your Pocket PC to start the installed programs. Click
e.g. Start > Programs > PlanMaker to open PlanMaker.

Note: When opening PlanMaker for the first time, you will be asked to enter your name and
contact info. This is not for registration purposes. It will allow you to insert your name, mailing
address, etc. in documents through the USERFIELD function. You can change this information at
any time.

Installing PlanMaker for Handheld PCs

Information on installing PlanMaker can be found in the confirmation e-mail
that you received after purchasing the software.

Note: If you are using Windows NT/2000/XP, Administrator login is re-
quired for installation.

Starting PlanMaker for Handheld PCs

Use the Start menu of your Handheld PC to start the installed programs.
Click e.g. Start > Programs > PlanMaker to open PlanMaker.

Note: When opening PlanMaker for the first time, you will be asked to enter your name and
contact info. This is not for registration purposes. It will allow you to insert your name, mailing
address, etc. in documents through the USERFIELD function. You can change this information at
any time.

Installing PlanMaker for Linux

Information on installing PlanMaker can be found in the confirmation e-mail
that you received after purchasing the software.
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Starting PlanMaker for Linux

To start PlanMaker for Linux, switch to the folder where PlanMaker is in-
stalled and start PlanMaker by executing the program file planmaker.

Note: When opening PlanMaker for the first time, you will be asked to enter your name and
contact info. This is not for registration purposes. It will allow you to insert your name, mailing
address, etc. in documents through the USERFIELD function. You can change this information at
any time.
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Screen Elements

Overview: Screen Elements

This chapter discusses the use of the individual components of PlanMaker's
application window.

The PlanMaker application window

Note: The illustrations in this manual were taken from PlanMaker for Win-
dows. Under other operating systems, some control elements may look
slightly different, however, their functions are identical to those described in
this section.

Pocket PC users: Please pay attention to the special notes for Pocket PC users
at the end of this chapter (page 22).
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Application Title Bar

At the top of PlanMaker's work screen is the title bar.

The title bar indicates the name of the program and the currently opened
document, e.g. PlanMaker - Worksheet.pmd.

Menu Bar

Under the application title bar is the menu bar.

The menu bar contains all commands of PlanMaker in the form of menus. To
execute a menu command, open the menu by clicking on it, then click on the
desired command.

Note for Pocket PC users: To open PlanMaker's menu bar on a Pocket PC, tap
on the Menu icon in the lower-left corner of the screen.

Toolbar

Below the Menu bar is the toolbar, which provides access to PlanMaker's most
frequently used commands.

Control strips like the toolbar facilitate easy access to application functions.
Every icon represents a certain command. If you click on an icon, the corre-
sponding command is executed.

Tip: If you move the mouse pointer to a control strip icon, a short explana-
tion of its function is displayed.

There are additional control strips in PlanMaker that you can display or hide
at will. Call up the View > Control strips command, or right-click on one of
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the control strips. A list of all available control strips will be displayed allow-
ing you to choose which control strips are visible.

Design your own control strips: You can customize the existing control strips, or
create your own.

Format Strip

Directly below the toolbar is the Format strip. Here you can access the most-
frequently used formatting functions – e.g., font, style, color, paragraph
format, etc.

For example, to select another font, click on the small arrow to the right of the
font name. This opens the font list drop-down menu, and allows you to select
a font.

Other icons in the Format strip are on/off formatting options such as the B
icon to apply a bold style to selected text.

Tip: If you move the mouse pointer to a control strip icon, a short explana-
tion of its function is displayed.

Edit Strip

Below the toolbar and the Format strip is the Edit strip.

The Edit strip contains the following control elements (on Pocket PCs, only
some are shown due to limited space):

Cell Address

The address of the currently active cell is displayed at the very left.
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Symbols and Input Field for Editing Cell Contents

To the right of the cell address are four icons and an input field.

Click into the input field to edit the content of the current cell. Or, to edit the
cell directly, simply click on the cell and begin typing.

The Edit strip icons have the following functions:

Icon Function

Calls up the Insert > Function command

Inserts the SUM function

Accepts the user input in the input field (identical to pressing the Enter key
(¢))

Cancels the user input in the input field (identical to pressing (Esc))

Document Window

With PlanMaker for Windows and Linux, every document you create or open
is displayed in its own document window. You can work on multiple docu-
ments simultaneously, and copy data between them at will.

A document window consists of the following components:

Title Bar

Provided that a document window is not maximized, it has its own title bar in
which the name of the document is displayed.
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Document

The document itself takes up most of the screen real estate. This is the work
area where you enter data, carry out calculations etc.

Worksheet Tabs

Below the document are the worksheet tabs.

A PlanMaker document can consist of several worksheets, which are layered
like a stack of paper sheets, one on top of another. With the worksheet tabs
you can switch between the individual worksheets in a document, create new
sheets and delete existing ones.

In the illustration above, the document consists of three worksheets, with
"Sheet1" the active worksheet.

Status Bar

At the bottom of the PlanMaker window, the status bar is displayed.

Tip: If you move the mouse pointer to a control strip icon or a command
menu, the status bar will display a short explanation of its function.

The status bar displays the following information (from left to right):

Example Explanation

On the very left, information is displayed about the control strip
icon or menu entry the mouse is currently pointing at.

Sheet1 The name of the current worksheet is displayed here.

Sum=6 Displays the result of the "immediate calculation". If only a
single cell is selected, its content is shown here. If several cells
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are selected, the sum of the cell contents is indicated (see also
the Calculation in status bar setting in Extras > Preferences).

This icon lights up in red if the worksheet contains circular
references. This usually indicates an erroneously written for-
mula – like e.g. a formula in cell A1 that refers to cell A1 itself.

If you click on this icon, PlanMaker selects the cell with the
circular reference. If you click again, it jumps to the next such
cell (if more than one such cells exist).

Ins Indicates whether Insert Mode (Ins) or Overstrike Mode (Ovr) is
active.

In Insert Mode (Ins), what you type is inserted before the existing
text.

In Overstrike Mode (Ovr), what you type overwrites the existing
text.

The default setting is Insert Mode. You switch between these
modes by pressing the (Ins) key.

AUTO Indicates the current input mode:

AUTO: Normal input mode – numbers are automatically recog-
nized as numbers, formulas (which means input that begins
with (=)), as formulas.

TEXT: Text entry mode – everything you enter is always inter-
preted as text, including formulas and numbers.

The default setting is AUTO. With the key combination
(Ctrl)(ª)(F4) you can switch between the two modes.

Important: If you switch to TEXT input mode, an apostrophe is
automatically prepended to all numbers and formulas you enter.
This converts these inputs into text which can no longer be used
for calculations. In order to turn text into numbers or formulas
again, edit the affected cells and simply remove the leading
apostrophe.

Special Notes for Pocket PC Users

On Pocket PCs, the application window looks a bit different: Menu bar and
most control strips are replaced by a single control strip called the Pocket PC
strip.
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This control strip lets you access the menu, the other control strips, and some
other important functions.

Pocket PC strip functions, from left to right:

 Open menu bar

 Object mode on/off

 Toolbar on/off

 Format strip on/off

 Edit strip on/off

 Status bar on/off

 Set magnification

 Row and column headers on/off
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PlanMaker Basics

Overview: PlanMaker Basics

This chapter discusses basic PlanMaker spreadsheet functions and terminol-
ogy. Users who have little or no experience in the use of spreadsheets should
read this chapter thoroughly.

Included in this chapter:

 The Structure of a Spreadsheet

 Moving Around in a Worksheet

 Entering Data and Deleting Data

 Undoing Changes

 Starting a New Document

 Opening, Printing and Saving a document

 Exiting PlanMaker

The Structure of a Spreadsheet

First, let's have a look on how spreadsheets are organized.
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Spreadsheets are divided into lines and columns. Every worksheet consists of
16384 rows and 256 columns. These are labeled as follows:

 The rows are numbered from 1 to 16384.

 The columns are labeled with alphabetic characters: A to Z, then AA to
AZ, BA to BZ, etc.

The matrix of rows and columns results in a cell grid.

Every cell has exact coordinates: B5 describes for example the cell in the fifth
line of column B (the second column). A3 would be the cell in the third row of
column A (the first column) etc.

These coordinates are referred to as the address of a cell.

The cell address is very important because calculations often refer to other
cells: If for example you want to put twice the value of cell A1 in cell A2, you
enter in cell A2: =A1*2.

In A2, twice the value of A1 is displayed now – if you change the value in A1,
the resulting calculation of cell A2 is automatically updated.
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Moving Around in a Worksheet

If you enter data in PlanMaker, it is always inserted into the active cell. A thin
gray frame, known as the cell frame, indicates the active cell.

In order to move the cell frame to another cell:

Mouse/Stylus: Click on the desired cell with the mouse or (on Pocket PCs or
Handheld PCs) tap on it with the stylus.

Keyboard: Use the arrow keys of your keyboard to move the cell frame.

Entering Data

In order to enter data into a cell, move to the desired cell using the arrow keys
or mouse and begin typing.

To complete your input, press the Enter key (¢).

To revert an input error, press the (Esc) key. PlanMaker restores the previous
cell content.

To edit the content of an already populated cell, double-click on it or activate
the cell and press the (F2) key.

Deleting Data

There are several ways to delete data from a document:

 Deleting only parts of the cell content

In order to delete only a part of the contents of a cell, double-click on it.
Alternatively, move to the cell and press the (F2) key to edit it.

 Deleting the entire cell content
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In order to delete the entire cell content, move to the cell and press the
(Del) key or call up the Edit > Delete.

 Deleting the contents of multiple cells

Select the cells and press the (Del) key or call up Edit > Delete.

Undoing Changes

Edit > Undo reverses changes made to a document, one by one, in reverse
order. The Undo command can be used repeatedly, if desired.

Reversing the Undo Command

There is a counterpart for the Undo command: Edit > Redo. This command
restores the action last undone and can also be used repeatedly.

Starting a New Document

To create a new document, call up the File > New command or use the
(Ctrl)(N) keystroke.

A dialog box will appear in which you can choose a document template for
the new document. To create a document without any additional formatting,
choose the standard document template, normal.pmv. Press Enter (¢) or click
OK to create the new document.

New window: If you have checked the New window checkbox in this dialog box,
the new document will appear in a new document window. Otherwise, the
current document is closed and the new document will be created in the same
window (this option is only available in Windows and Linux).
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Opening a Document

To open an existing document, call up the File > Open command or use the
(Ctrl)(O) keystroke.

In the dialog box that now appears, navigate to the document and click on
Open.

You can choose which drive and folder to display through the Look in drop-
down list. To switch to a different drive or folder, click on the arrow to the
right of this list to access the drop-down menu, and select the desired drive
and/or folder.

New window: In order to open the document in a new window, check the New
window checkbox. Otherwise, the current document will be closed and the
new file will be opened in the same window (this option is only available in
Windows and Linux).

Opening Other File Formats

PlanMaker can also open files created in other programs. Just select the
appropriate file type in the Files of type dropdown menu.
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Using QuickPaths

QuickPaths are a feature that lets you assign a name to often-used file paths.
To use QuickPaths, click on the QuickPath button.

File Manager

Click on File Manager to access the built-in file manager. The file manager
shows a list of your documents and lets you search, open, print, view, and
rename them.

Previewing a Document

To preview a document from within this dialog, click on Preview.

List of Most Recently Opened Files

Tip: At the bottom of the File menu is a list of recently opened documents.
Click a name on the list to reopen the document.

Pocket PC: On Pocket PCs, the recently opened documents are accessed from
the Recent menu.

Printing a Document

Note: Printing is not supported on Pocket PCs.

If you wish to print the current document, call up the File > Print command or
use the (Ctrl)(P) keystroke.
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A dialog box will appear in which you can select the number of copies and
which pages to print. The dialog box defaults to printing one copy of all pages
of the document.

Saving a Document

To save a document call up the File > Save command or use the (Ctrl)(P)
keystroke. If the document has not been saved before, PlanMaker will request
a document name before saving.

Saving under a Different Name, or in a Different Folder

PlanMaker also provides the File > Save as command. This command saves
your document as well, but gives you the opportunity to assign a different file
name or save it to a different folder.
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Saving in a Different File Format

You can store the document in a different file format when using the File >
Save as command. Select the desired file format from the Files of type drop-
down menu.

Saving All Open Documents

If you have several documents open, call up File > Save all to save all open
documents using their current name. PlanMaker checks the documents and
saves only those documents that have been changed.

Exiting PlanMaker

To exit PlanMaker, use the File > Exit command.

If open documents have been modified, PlanMaker will automatically ask you
if you want to save them before exiting.
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The PlanMaker Tour

Overview: The PlanMaker Tour

Users unfamiliar with spreadsheets should read the following section thor-
oughly. More advanced users are encouraged to cull as needed.

Note: The illustrations in this manual were drawn from PlanMaker for Win-
dows. Under other operating systems, some control elements may look
slightly different, however, their functions are identical to those described
in this section.

Five Minutes of Theory…

If you plan, for example, a computer purchase, you must compare various
systems, which consist of individual hardware components: you will need a
PC, a monitor, and a printer. One vendor may offer a competitively priced
computer; another vendor may offer an inexpensive monitor, etc. Which is
the best option?

In order to find this out, you have to add up the prices. So, grab your pocket
calculator, type in the numbers one by one, jot down the result – and become
frustrated: With every new offer, the game begins anew, even though the
method of calculation never changes, only the values do.

Such calculations can be carried out much easier with the help of a spread-
sheet application.

The first technique you will learn when using PlanMaker, is to employ "vari-
ables." Variables help you to generate abstract formulas, without the use of
actual number (or dollar) values. For instance:

computer + monitor + printer = total price
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abstracted:

a + b + c = d

Without spreadsheets, such a formula has only practical benefit if you use a
programmable calculator - you can enter the formula once, and can execute it
multiple times. The calculator requests the values one by one and then shows
the total value. Not much of an improvement over repeated individual calcu-
lations...

First Steps with PlanMaker

After these preliminary thoughts, now is a good time to look at how such
tasks can be set-up using PlanMaker.

When you start PlanMaker, the following screen will appear (Windows
version):
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Most of the application window is taken up by your new worksheet. On the
top, it is bordered by a row of alphabetic characters, on the left by a column of
numbers.

Let's have a closer look at the worksheet:

The Basic Structure of a Worksheet

As you already know from chapter "PlanMaker Basics", a worksheet is divided
into rows and columns. This is also visible through the gray lines that are
displayed in the worksheet.

A dark gray frame that we call the cell frame surrounds the cell in the upper
left corner. The cell frame indicates which cell is currently active. When
entering data, it is always placed in the active cell.

Press the (¼) and (Æ) keys to move the cell frame (active cell) from one cell to
another. Take a look at the Edit strip above the worksheet: at the very left,
PlanMaker displays the address of the currently active cell. The address always
consists of one to two alphabetic characters and a number:

A1 means column 1, row 1.

A5 means column 1, row 5.

D5 means column 4, row 5, etc.

The fact that every cell has a unique address is the key to all functions of a
spreadsheet. Remember the variables a, b, c we talked about before? In Plan-
Maker, the cells are used as variables. Therefore, you can enter calculations in
a cell that refer to other cells in your worksheet – and, for example, calculate
the sum of several cells in another cell.

Entering Values and Formulas

Enough theory for now! Let's create our first calculation.

First we type in the price for the personal computer, under that the price for
the monitor, and under that the price for the printer.
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Use the arrow keys to go to cell B2 and enter the value 1499. The value ap-
pears both in the chosen cell and in the Edit strip above the table.

Note: Do not make the mistake of typing the letter "O" or "o" instead of the
numerical digit "0". Computers make a clear distinction between letters and
numbers. PlanMaker would accept the input but interpret it as text. When
attempting to calculate with it, PlanMaker will generate an error message.

Press the Enter key (¢) now to finish your input. The cell frame moves down
one row to cell B3. Type the value 899 here and in the row below that type the
value 499.

Tip: If you entered a wrong value and have already pressed (¢), you can still
correct your mistake. Move the cell frame to the cell with the error and enter
the correct value. As soon as you press (¢), the old content is overwritten by
the new input. You can also edit the content of already filled-out cells by
pressing the (F2) key.

Entering Formulas

Let's enter our first formula:

In order to calculate the total cost of our computer equipment, we have to add
up the unit prices. This is simple to do:

Go to cell B5 and type an = (equal sign). The equal sign shows PlanMaker that
you would like to begin entering a formula.

Now enter the formula. For this purpose, you use the cell addresses as "vari-
ables". Type in:

=B2+B3+B4

Note: Cell addresses are not case-sensitive – you can type them in either
upper- or lowercase.

As soon as you press (¢), you can see the result of your first formula:
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See what happens if you change the numbers in the cells. Replace 899 by 799
or some other value. As soon as you press (¢), the result of the calculation is
updated immediately.

You see: Regardless of what cells B2, B3 and B4 contain, PlanMaker will
always sum them up. If you get a quote for a computer system in which only
the price for one component has changed, you only need to update the one
value, and the new total price will be displayed in cell B5.

The "SUM" Function

The example above is a method of adding up several numbers. This method is
adequate for a few numbers, but is certainly too cumbersome for adding 50
numbers - that would be one long formula! However, there are better ways to
achieve this: the arithmetic functions of PlanMaker.

Let us find out more about them! Make cell B5 the current cell. It contains the
formula you previously entered.

First, delete the old formula by pressing the (Del) key, or by simply overwrit-
ing the existing cell content. Now enter the following formula:

=SUM(B2:B4)

After you press (¢), you can see the result in the cell.

PlanMaker has over 320 built-in mathematical functions - and one of them is
SUM. The SUM function calculates the sum of the values your formula refer-
ences. The expression in parentheses after the function name tells PlanMaker
where to start and stop totaling:

You have directed PlanMaker to start adding in cell B2 and stop in cell B4.
Between cell B2 and cell B4 sits one cell - B3, and it is included in the sum-
ming as well. You could easily have specified a larger range, such as B2:B123.
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The notation starting cell:ending cell can also be used when both row and
column changes. If, for example, you enter B2 as the starting cell and C4 as
the last cell, these two coordinates form the corners of a rectangle. The for-
mula =SUM(B2:C4) would sum all numbers contained within this rectangle.

Working with the Sum Icon

There is an even easier way to insert the SUM function:

Delete the contents of cell B5 again.

Now click on the sum icon  in PlanMaker's edit strip. Move your mouse
pointer to cell B2 and select cells B2, B3, and B4 by pressing and holding the
left mouse button while you move the mouse pointer down to cell B4.

If you look at the Edit strip while you do this, the input area will display your
new formula. PlanMaker builds the formula on the fly, while you are dragging
the mouse pointer down. As soon as your formula is complete, release the
mouse button and accept the formula in the Edit strip by pressing (¢).

As you have seen, there are several ways to enter formulas in PlanMaker. All
these methods have their advantages and disadvantages. As you become
better acquainted with PlanMaker, you will automatically pick the best
method for each specific situation.

Working with the Insert > Function dialog

You now know the basics of working with a spreadsheet.

To get an impression of the large number of functions PlanMaker supports,
call up the Insert > Function command now. A dialog box will appear that
contains all the functions PlanMaker supports.
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Tip: You can also call up this command by pressing the function key (F7).

Let's try another function: Suppose we want to calculate the average value of
our three numbers in the table:

Press (Esc) to dismiss the dialog box, return to the worksheet, and delete the
contents of cell B5 again.

Call up the Insert > Function command. Choose the category All functions in
the left list. Now scroll through the right list down to the "Average" function.
Double-click on Average.

PlanMaker now places the Average function into the input field of the dialog
box:

Average()

In order to complete the formula, enter the cell range B2:B4 between the
parentheses.

Alternatively, you can select the cell range right in the worksheet: left-click on
cell B2, then drag down the mouse to cell B4 (as you did in a previous exam-
ple). If the dialog box covers the cells you want to select, simply drag the
dialog box out of the way.

The completed formula should look like this:
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=Average(B2:B4)

If you click on the Insert button now, this formula is placed into cell B5 and
calculated immediately.

Going Three-dimensional

PlanMaker documents are not limited to single worksheets. If required, you
can stack several worksheets on top of each other – just like a pile of paper.
PlanMaker documents are therefore also called workbooks. Each workbook
can contain up to 256 worksheets.

The main advantage of this is that calculations in one worksheet can also refer
to cells in other worksheets of a workbook – this way you can create three-
dimensional spreadsheets.

An example: If you maintain the financial records of three branches of a
company on three worksheets, you can create a fourth worksheet that sums
the financial results of the three branches, giving you an integrated view of
the company finances.

To add a new worksheet to a workbook, use the Table > Worksheet > Insert
command. To change between the individual sheets, use the worksheet tabs
on the worksheet register.

Simply click on the worksheet tab to switch the currently active worksheet.

Changing the Layout of Worksheets

Let's return to our first sample worksheet and improve the visual layout.
PlanMaker has many formatting functions that let you fine-tune how the
worksheets look.
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Adding a Heading

What is missing from our worksheet is a heading. So, let's enter a headline
and increase the font size to make it stand out.

Click on cell B1 to make it the active cell. Type e.g. the following text:

My first worksheet(¢)

Changing Character Formatting

Move the cell frame back to cell B1 again. Open the font list in the format
strip by clicking the small triangle to the right of the font name.

PlanMaker now displays a list of all fonts installed on your computer. Choose
the Tahoma font – or any other font you like. Now, open the list with the font
sizes – this list is immediately to the right of the font list. Choose a font size of
24 point.

The remaining elements of the format strip allow you to change the color of
text, and to apply various formatting attributes: B turns on bold printing, I
switches to italics, U underlines the text etc.

Charts

At the end of this tour, let us have a quick look at charts.

In spreadsheets consisting of nothing but long columns of numbers, it is often
hard to interpret their meaning. PlanMaker offers easy ways to turn raw
numbers into charts that get the point across.
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To insert a chart in a worksheet, select the values you want to base your chart
on and call up the Object > New Chart Frame command. Use your mouse to
draw a rectangle on your screen. This rectangle determines the position and
size of the chart. After drawing the rectangle, a dialog box will open that lets
you define the type (pie chart, column chart, etc.) and the graphical options
(colors, headline, legend, etc.) of the chart.



Quick Start PlanMaker 2004 Index  •  43

Index
Entries in Boldface represent menu
commands.

B
Basics 25

C
Cell frame 27

Circular reference 22

D
Delete (Edit menu) 28

Document window 20

E
Edit > Delete 28

Edit > Redo 28

Edit > Undo 28

Edit strip 19

Exit (File menu) 32

F
File > Exit 32

File > New 28

File > Open 29

File > Save 31

File > Save all 32

File > Save as 31

Format strip 19

I
Installation 11

Handheld PCs 15
Linux 15
Pocket PCs 14
Windows 11

L
LAN 12

M
Manual 7

Menu bar 18

N
Network 12

New (File menu) 28

O
Open (File menu) 29

P
PlanMaker Tour 33

Preview 30

R
Redo (Edit menu) 28

S
Save (File menu) 31

Save all (File menu) 32

Save as (File menu) 31

Starting PlanMaker
Handheld PCs 15
Linux 16
Pocket PCs 15
Windows 12

Status bar 21

System requirements 8

T
Title bar 18

Toolbar 18

U
Undo (Edit menu) 28

Upgrade 12


